+1
Fixed

The scene is embedded on a domain that is not enabled in your account.

Tiago Almeida 7 years ago updated by Gil Sideman 8 months ago 4
Hi,

i've added my domian to Licensed Domains into my account but when i call the page http://vieira.staging.excentric.pt/ts... its showing me the error message.

Those it need to get some validation from sitepal ?

regards

Answer

Dear Tiago -

I believe the problem is that you copied our example to your page, but did not replace our embed code with yours.
Consequently - your page is loading the example from our API Demo account.

If you configured the domain in your own account, then as soon as you swap in your own embed code it should start working.

Hope this helps!
Gil
SitePal Team

Hi team,

I am also getting same issue. Scene created from my account and i have embedded in to my site. Avatar coming but audio not working. showing this error.

"The scene is embedded on a domain that is not enabled in your account."

Please help how to fix it.

Thanks

Hello Parimal - 


First - please verify that you have added your site domain to the licensed domains for your account.

For dynamic TTS calls (sayText and sayAIResponse) the page domain must be specifically enabled in you Account Info page. This is a security feature.


If you did enable, please check again to verify the domain name was entered correctly. No path or protocol details should be added - just your domain name. 

eg. 

www.mycompany.com  or  mycompany.com 

for development you can also inter ip address or localhost.

If you did everything right, but it still won't speak, please send a note to support@sitepal.com - and include a link to your page, where the problem can be seen.

We will take a look and advise. 


Regards,

Gil

The SitePal Team