+1
Under review

full body avatar- Google chrome: grey overlay on start

tony jackson 4 years ago • updated by Jonathan Frank 3 years ago 14
Sept 2015 Used to work fine, but now with a full body avatar and transparent background, Chrome shows a grey semi-transparent overlay with a play button (looks like a HTML5 thing), which must be clicked before the scene starts. It works fine in Firefox and Safari, with the scene starting on load.
Note this is not related to the site I am hosting it on as it behaves in the same way in the Sitepal preview and also with the full body avatars on the sitepal home page. It was first picked up by my customers, so is not related to my PC either.
Something has clearly changed this month in either Chrome or the Sitepal code and needs fixing asap!!
I have raised a fault ticket, but I know response is a bit patchy at best, so hoping for some feedback from others.
A little more research and it appears there's a google security settings thing under privacy - content settings - plugins.
The default is "detect and run important plugin content". This causes the grey box.
If you change this to "run all plugin content", then it works as expected.
Bad news is that the selection is aimed at improving security and I can't go around recommending to my customers to choose to "run all plugin content" as I have no idea what this will unleash !
I don;t know if Google are just ahead of the others and this will happen with all of them going forward, but it's a real pain with the flash version!!
I haven't found it, but is there a way to force an HTML5 version first with Flash fallback ???
Under review
Tony -
Your characterization of the problem is spot on.
The full body character currently takes advantage of Flash where available - and HTML5 otherwise.
We will be making a change to play back using HTML5 on Chrome.This change will be made in the next several days - it is being tested now.
Regards,
Gil

This product does not auto load in Chrome. Customer service does not respond.....

Jonathan -


It normally does load in Chrome - we would need to look at your specific page and advise further.

How long ago did you write to support?

Our response time is within 2 business days, though normally we respond on the same day.


You can post the link to your page here if you like - or wait for support to respond & send it over that way.

Regards

Gil




i Gil,

I sent two emails one went to the sales department by default. The other email was sent on
Monday. I had your service back in 07 and it worked really well for my business.

www.floutinwithdisorder.com

Thanks,
Jonathan Frank

Hi Jonathan -

Love the website! It loads fine for me in Chrome.

Do you see a 'grey rectangle' over the SitePal character that you need to click before it plays?

Is that what you mean by 'does not auto-load'?


If that's the issue - this is due to a setting in Chrome which you can easily change.

here's how -

Goto Settings

Click on 'Advanced settings' at bottom

Under 'Privacy' click on 'content settings'

Under 'Plugins' select 'Run all plugin content'.


If this does not work for some reason - uninstall and reinstall Flash.

We are working on a technology update that will eliminate such issues for our Classic characters. This update should be out within a few weeks.


Hope this helps - let me know.

Gil


Hi Gil,


It has a gray transparent overlay with a play symbol only on Chrome.

Thanks I will try your suggestions.


Jonathan

Many Thanks Gil! that did the trick!!!


Jonathan Frank

Great news, thanks for the quick response. Good luck with the change. Would be very interested to hear how you deal with transparent background on HTML5 player. It's not obvious to me how you do it, although I know you must have found a way because it works on my mobile version!
Hi Gil,
Have you made any progress on this issue yet? I notice your full body avatars are still Flash
My customers are bugging me now for an alternate solution, so would welcome an update.
Thanks
Tony
Hi Tony - we're working on it. Some problems have been noted, and are being addressed. The process should be concluded within several days.
I have an update for you that might be interesting.
I'm guessing this shouldn't work and might stop working after a while, but I've found a way around the issue.
If you place the avatar inside an iframe and set the iframe container to display: none, then add some javascript to change this to display: block after a time using setTimeout ( I set it to 3secs for now), it mysteriously works.Try it yourself please and see if it works for you.
Thanks
Tony
Hi Tony -
This issue is now resolved.
Full body characters are now displayed in HTML5 on Chrome (as well as on mobile devices of course)
We will apply the same to other browsers in the coming weeks - as we gradually phase out Flash.

Let me know if you notice any problem.
Best,
Gil

ps. interesting workaround - good to know!

Fabulous,
I've checked my my site and it works perfectly, really nice.
Great work, I appreciate it.
I have now asked my client to take up the Gold package!