+1
Answered

Play video on iOS problem.

gianfranco de villa 9 years ago in SitePal Studio updated 8 years ago 15
Hi,
I have done some scenes. They are correctly showed on browser.
In html code there is only code generated by publisher as embedded scene.
No TTS and javascript. But on iPhone/iPad I see only 3 seconds of movie without voice.
Can you help me to solve this problem ?

Thanks.
Gianfranco

Answer

Gianfranco -
Looking into it. Can you post a link to the page where the problem can be seen?
Thanx,
Gil
SitePal Team
Hi Gil,

the page is on 173.248.136.115 site. Here is a link to page named TestWithoutSayText.htm.

Now video is working.
Meanwhile I have changed audio; now on iPad is playing old audio, while on pc browser is playing new audio.

FIY, I change audio calling API: mngCreateTTSAudio, mngEmbedScene.

Thanks
Gianfranco
The experience you describe is likely the result of browser caching.
If your changes are not immediately applied, try clearing browser cache.
Anyway - glad it is working now - works for me too - character speaks when I click the start button.
Let us know if any conclusions regarding the ipad playback.
Regards
Gil
SitePal Team
Hi Gil,

would seem to be a browser caching problem... but it is not so.

For safety I have done other tests:
- after dropped down safari to refresh cache, I reload it with same iPad and allways video say different from pc.
- so I have called the page from my iPhone (first call, never used)... identical result
- more... I have asked to a friend of mine to connect with his iPad...same result !

So I have changed scene to do a better test.

On Sitepal I have many scenes, similar and all without audio.

Then from my server I execute a call to mngCreateTTSAudio assigning it to a scene.
All works fine.
Then get code embedded HTML/javascript in my page - same as previous - and again:
on pc browser flash play correctly
on iPad, iPhone video is mute (as if the scene had remained as before without connecting to the new audio)

After that, I have registered a new audio on scene with mngCreateTTSAudio and mngEmbedScene to retrieve code embedded.
Now also pc browser is playing old audio and not the new !!

This happens while on sitepal site scene is working correctly.
To assure that is not browser caching -apart to refresh cache- I have used other pc.

Are you sure that your server is correctly refreshing scenes with changed audio ?
Or, better, can you indicate me where I am wrong ?

Thanks.
Gianfranco
Gianfranco -

Your implementation has uncovered a missing piece in our iOS solution. The video version of the Scene (which is played on iOS devices) is not currently being regenerated when the Scene is updated through management API calls.

We will update the implementation and correct this lapse. This update has been added to our development plan and should require about 2 weeks.

However please note that video availability will not be immediate. When a Scene is updated, the video version of the updated Scene becomes available up to 1 to 2 min later. Hope that can work for the implementation you have in mind.

Gil
Hi Gil,

My implementation may be more reactive, so 2 min are too much time to wait.
I have thinked about this issue , but do not found any useful solution.

Now that problem with mngAddScene api and apostrophe char has been resolved
I have tried also to use it...but do not return a scene usable. In this case neither Android nor for iOS.
First remain without audio, latter send a message type "file xxx.mp4 do not exists".

So at moment I stay on hold with iOS devices and will release only app for android.

Thanks anyway for your time.
Gianfranco
The missing mp4 problem will go away when we update the implementation - however, as noted the video generation takes a bit of time, the mechanism was not designed to be 'real time'.

That said, we will see what we can do to tighten the video generation times.
Gil
Hi Gil,

I have one (at moment...) more question about: is for sure that time for create iOS video is max 2 min ?

May be I have found a solution for my problem....but it is working only if delay is within 2 min.

Thanks.
Gianfranco
Gianfranco -
The implementation is now being tested in our staging environment and we are finding average times of less than 1 minute, and we are not seeing any times longer than 90 sec.

We should have this deployed within a day or two - at which point you could test for yourself.
Gil
Gianfranco -
The implementation has now been deployed. Looks like it requires more time on the live environment due to CDN purging. Take a look and see if it matches your needs.
We are looking at possible ways to make it update faster.
Will advise.
Gil
Hi Gil,

Implementation is working. Thank you.

But again I am thinking about iPhone/iPad flash question.

What about automatically converting flash animation in HTML5 file ?
Is possible ? Have you experimented this way ?

Thanks.
Gianfranco
Gianfranco,

Glad to hear it is working for you.
Is the update time acceptable for your needs?

Regarding HTML5 -
Our review indicates that HTML5 is not ready to support audio visual animation - with the features that we require to run a speaking animated avatar.
There are multiple problems - including very limited performance, missing key features, and spotty/inconsistent implementation of features among different browsers.
Hence the only thing we can support on a platform that does not support Flash is video playback.

Regards
Gil
Hi Gil,
I resume this thread because now I have some trouble.

I create my scene calling api mngAddScene and mngEmbedScene. All is working fine.
With web browser (Chrome) I see scenes correctly.

Now I have an app Android and with simulator (BlueStacks) on W7 I run the app.
At end of game the app open browser to show html page. Again this is working fine and a presentation scene (fixed and not created at moment) is playing correcty.

Finally, in html page there are some links to other scene. If I call the link I get page of scene (es. http://content.oddcast.com/vhss/ccs2/....
So appear the message : "The requested URL vhss/ccs2/vhss/user/614/2465549/video/video_2260046.mp4 was not found on this server"

Sorry for my bad english, I hope I was clear.
Where I am wrong ?
Can you help me ?

Thanks.
Gianfranco
Gianfranco -
Thanks for letting us know.
Can you post a link to the page where the problem can be seen? That would be very helpful. Or please send the link to support.
We will take a close look tomorrow (Monday) and get back to you.
Regards
Gil
Gil,
let me specify my system.

I have a datasnap/rest server that respond to request from app (on mobile) creating scene calling api mngAddScene and mngEmbedScene.
After that, when requested, the server send an html page with js to play scene previously registered.
If I do this directly from pc browser all goes fine.
You can try it with this
http://173.248.136.115:35813/datasnap...&
and after same secs you get the {"result":[{"GeneraScene":"OK"}]}.

The scenes are made, so you can call
http://173.248.136.115:35813/request_...&
and you get "thank_you" scene that plays fine (allways, on pc browser and android).
In web page, under the scene, there are 3 links to scenes generated on-fly: these play fine on pc browser,
while on android (I use BlueStacks to simulate an android mobile) you should get message "The requested URL vhss/ccs2/vhss/user/614/2465549/video/video_xxxx.mp4 was not found on this server"

Note that scenes generated will be deleted after 25 min.

Thank you.
Gianfranco